Calendly may load slowly for some users
Incident Report for Calendly
Resolved
This issue is resolved and Calendly is working as expected for all users. If you have questions, please reach out to support.
Posted May 11, 2021 - 15:50 EDT
Monitoring
Calendly should be operational again. Our team is monitoring the issue. If you have questions, please reach out to Support.
Posted May 11, 2021 - 13:20 EDT
Identified
The Calendly app may load slowly for some users. Our team is working on resolving the issue.
Posted May 11, 2021 - 12:07 EDT
This incident affected: calendly.com.