Users may experience intermittent errors when booking on Calendly
Incident Report for Calendly
Resolved
This incident has been resolved.
Posted Jan 12, 2024 - 13:41 EST
Identified
Our Engineering team has identified the root cause and is implementing a solution
Posted Jan 12, 2024 - 13:34 EST
Investigating
Some users may intermittently experience errors when attempting to make a booking on Calendly. Our Engineering team is actively looking into this and will provide updates as this investigation progresses.
Posted Jan 12, 2024 - 13:08 EST