Users on the Free or Trial Plan may experience issues accessing their Calendly.com account
Incident Report for Calendly
Resolved
This incident has been resolved.
Posted Jan 24, 2024 - 16:00 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 24, 2024 - 15:35 EST
Investigating
We are currently looking into a known issue where users on the Free or Teams Trial Plan may be unsuccessful in accessing their Calendly.com account.
Posted Jan 24, 2024 - 15:24 EST
This incident affected: calendly.com.