Apple iCloud Services are Experiencing an Outage
Incident Report for Calendly
Resolved
This incident has been resolved by Apple. If your iCloud calendar was disconnected, please go to your Calendar Connection page to reconnect it to Calendly.
Posted Mar 21, 2022 - 15:56 EDT
Monitoring
Apple has implemented a fix and we are monitoring the issue.
Posted Mar 21, 2022 - 15:00 EDT
Identified
Apple iCloud calendar services are currently experiencing an outage that is preventing Calendly from connecting to some users calendars and displaying availability.
Posted Mar 21, 2022 - 14:30 EDT
This incident affected: Calendar Integrations (iCloud).