Outlook Desktop Issues
Incident Report for Calendly
Resolved
This incident has been resolved. Please reach out to Calendly Support if you have questions or issues.
Posted Jan 22, 2021 - 12:35 EST
Monitoring
Customers using Calendly with Outlook Desktop should see improvement. We are continuing to monitor. Please reach out to Calendly Support if you have questions or issues.
Posted Jan 22, 2021 - 12:27 EST
Investigating
Customers using Calendly with Outlook may be experiencing issues at this time. Our engineering team is investigating.
Posted Jan 22, 2021 - 12:25 EST
This incident affected: Calendar Integrations (Outlook Desktop).