Google bookings are inconsistently being created post-booking
Incident Report for Calendly
Resolved
What Happened?
For those customers that created or edited a meeting on September 19, 2023 between 3:36pm - 4:27pm ET, a small group of those meetings were incorrectly canceled due to a bug.

On your Calendly dashboard please check your Scheduled Events tab to identify if any meetings were affected and take the appropriate next steps.

We sincerely apologize for the inconvenience this caused you and our engineering team is performing a full root cause analysis to ensure this doesn’t happen again.
Posted Sep 19, 2023 - 19:34 EDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 19, 2023 - 16:41 EDT
Identified
We’ve identified an issue where events scheduled with a Google Calendar account between 3:36 pm and 4:27 pm ET were unintentionally canceled, encompassing both new and rescheduled meetings within that timeframe.

New bookings are operating as intended, and we are actively investigating the impacted bookings.
Posted Sep 19, 2023 - 16:22 EDT
This incident affected: Calendar Integrations (Google).