Investigating issues with Outlook Desktop Client Integration
Incident Report for Calendly
Resolved
The AWS and Heroku issue have been resolved and functionality has been restored for all users. We are continuing to monitor, but all should be functioning properly.
Posted 16 days ago. Aug 31, 2019 - 15:48 EDT
Identified
Our developers have confirmed that issues reported by Heroku and AWS are affecting our Outlook Desktop users in the following ways:
- The booking page will not load if a user has an Outlook Desktop connection
- Users are unable to set up a new Outlook Desktop connection
- The Calendar Connection page will not load for users with an existing Outlook Desktop connection

Our team will continue to monitor for any changes in status and communicate via this channel.
Posted 16 days ago. Aug 31, 2019 - 09:56 EDT
Update
Our team has confirmed that our customers using Outlook Desktop will experience errors when connecting or booking. Our developers are continuing to investigate.
Posted 16 days ago. Aug 31, 2019 - 09:28 EDT
Investigating
Our developers are currently investigating reports of errors that may impact our customers who use our Outlook Desktop Client integration. We will update here as we know more.
Posted 16 days ago. Aug 31, 2019 - 09:21 EDT
This incident affected: Calendar Integrations (Outlook Desktop).