Some users experiencing error when signing up for Calendly using Outlook email
Incident Report for Calendly
Resolved
A fix has been deployed, and this issue is now resolved.
Posted Jul 20, 2022 - 16:47 EDT
Monitoring
We are currently working with Microsoft to monitor the status of this issue.
Posted Jul 20, 2022 - 13:00 EDT
Update
We are continuing to investigate this issue.
Posted Jul 20, 2022 - 12:36 EDT
Investigating
We are currently investigating an issue in which a small subset of new customers signing up for Calendly accounts using an Outlook.com email address via Google Chrome are met with an error during signup.
Posted Jul 20, 2022 - 12:26 EDT
This incident affected: calendly.com.