Calendly Chrome Extension is currently not available
Incident Report for Calendly
Resolved
The Calendly Chrome extension is now available on the Chrome Web Store.
Posted Jan 01, 2025 - 17:55 EST
Update
We are continuing to work on a fix for this issue.
Posted Dec 31, 2024 - 14:29 EST
Identified
The Calendly Chrome Extension is not currently available for download. We are working on getting the listing back up in the Chrome Web Store. Users who have the extension installed should be unaffected.
Posted Dec 31, 2024 - 14:28 EST
This incident affected: Calendly for Chrome.