Delays in emails sending and events pushing to calendars
Incident Report for Calendly
Resolved
This incident has been resolved.
Posted Nov 11, 2021 - 14:50 EST
Update
We are seeing improvements on this issue, but continuing to monitor.
Posted Nov 11, 2021 - 14:13 EST
Update
We are continuing to see processing delays and are actively triaging the event processing.
Posted Nov 11, 2021 - 13:30 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 11, 2021 - 13:04 EST
Monitoring
Calendly experienced elevated error rates and higher than normal latency in processing events related to calendar connections, webhooks, email sends, video conferencing, and SMS processing. Queues are in the process of recovering and delivery is rapidly catching up.
Posted Nov 11, 2021 - 12:41 EST
Identified
Our engineers have identified the errors causing this delay. We’ve taken steps to remediate and are seeing signs of recovery
Posted Nov 11, 2021 - 12:12 EST
Update
We are continuing to investigate this issue.
Posted Nov 11, 2021 - 12:01 EST
Investigating
We are experiencing delays in emails sending and events pushing to calendars
Posted Nov 11, 2021 - 11:56 EST
This incident affected: calendly.com, Notifications, Calendar Integrations (Google, Outlook.com & Office 365, Outlook Desktop, iCloud, Exchange), Third Party Integrations (Zoom, Salesforce), and API and Webhooks (Webhooks).