Intermittent issues with Exchange / Outlook
Incident Report for Calendly
Resolved
Our team has resolved the issue with Exchange and Outlook events not being added to calendars. Please reach out to Support if you have questions.
Posted Apr 06, 2021 - 14:10 EDT
Identified
Some Exchange and Outlook users may see events not being added to their calendar. Our team is working to resolve the issue.
Posted Apr 06, 2021 - 11:41 EDT
This incident affected: Calendar Integrations (Exchange).