Customers may be experiencing issues with rescheduling events

Incident Report for Calendly

Resolved

This incident has been resolved.
Posted Jun 09, 2025 - 15:41 EDT

Monitoring

Our product is currently working as expected, with no disruptions observed. We are continuously monitoring system performance to ensure a seamless experience.
Posted Jun 09, 2025 - 15:01 EDT

Identified

We have implemented a fix to resolve unexpected rescheduling of events. Some users received notifications about rescheduled events without making any changes themselves. This issue affected a limited number of customers. We are closely monitoring the situation and will provide further updates as needed.
Posted Jun 09, 2025 - 14:10 EDT

Investigating

We are currently investigating an ongoing issue affecting event rescheduling functionality.
Posted Jun 09, 2025 - 12:45 EDT
This incident affected: calendly.com and Notifications.