iCloud Integration Issues
Incident Report for Calendly
Resolved
Apple has resolved the issue. iCloud users should no longer be impacted.
Posted 6 months ago. Mar 19, 2019 - 18:57 EDT
Investigating
We are currently investigating issues with iCloud.
Posted 6 months ago. Mar 19, 2019 - 18:35 EDT
This incident affected: Calendar Integrations (iCloud).