Outlook Desktop Plugin
Incident Report for Calendly
Resolved
Outlook Desktop functionality has been restored for all users.
Posted 6 months ago. Jun 26, 2018 - 18:44 EDT
Investigating
We are currently investigating issues with our Outlook Desktop integration. Outlook Desktop users may experience disruptions with syncing and booking.
Posted 6 months ago. Jun 26, 2018 - 15:55 EDT
This incident affected: Calendar Integrations (Outlook Desktop).