iCloud calendar connection issue
Incident Report for Calendly
Resolved
iCloud calendar connection support has been restored.
Posted 12 days ago. Jul 11, 2019 - 13:23 EDT
Investigating
We are proactively investigating an issue that may impact some iCloud users from connecting their iCloud calendar on the calendar connection page. We are working with our partners to ensure that service is restored as quickly as possible.
Posted 12 days ago. Jul 11, 2019 - 09:58 EDT
This incident affected: Calendar Integrations (iCloud).